The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #13510

--parseonly doesn't always issue deprecation warnings in master

Added by Patrick Carlisle over 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:03/29/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:3.0.0
Affected Puppet version: Branch:https://github.com/puppetlabs/puppet/pull/621
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

I’m getting failures in acceptance/tests/ticket_6928_puppet_master_parse_fails.rb

It seems to have to do with the ordering of arguments. On my local system running bare puppet master --parseonly gives the correct message but adding another long form option after makes it just display See 'puppet help' for help on available puppet subcommands

History

#1 Updated by Patrick Carlisle over 2 years ago

bisect gave me

e78a77edbd2880dd6c882efcaa7408a16176bd14 is the first bad commit
commit e78a77edbd2880dd6c882efcaa7408a16176bd14
Author: cprice <chris@puppetlabs.com>
Date:   Fri Mar 16 16:31:44 2012 -0700

    (#7749) doc / tests cleanup

#2 Updated by Chris Price over 2 years ago

  • Status changed from Accepted to In Topic Branch Pending Review
  • Branch set to https://github.com/puppetlabs/puppet/pull/621

#3 Updated by Chris Price over 2 years ago

  • Assignee deleted (Chris Price)

#4 Updated by Josh Cooper almost 2 years ago

  • Status changed from In Topic Branch Pending Review to Merged - Pending Release
  • Target version changed from 3.x to 3.0.0

#5 Updated by Matthaus Owens almost 2 years ago

  • Status changed from Merged - Pending Release to Closed

Released in Puppet 3.0.0rc1

Also available in: Atom PDF