The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #13559

Telly requires a single console log output mechanism, but will have two after PMT merges up.

Added by Anonymous over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:03/30/2012
Priority:UrgentDue date:
Assignee:Chris Price% Done:

0%

Category:logging
Target version:3.0.0
Affected Puppet version: Branch:https://github.com/puppetlabs/puppet/pull/692
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

While the PMT work was underway, a new console output mechanism was needed. This was added in 2.7.x, the stable series, as an addition used only in the PMT code itself.

Now that has merged to the main tree, and we are starting to look at Telly, we need to have this fixed. We can’t ship Telly with two log output mechanisms.


Related issues

Related to Puppet - Bug #14675: Color is not working in master but is in 2.7.x Closed 05/23/2012
Related to Puppet - Bug #16728: puppet agent --verbose has lost notice tag Closed 10/03/2012

History

#1 Updated by Anonymous over 2 years ago

  • Status changed from Accepted to Needs Decision

Pieter, this needs decisions about the scope of the change, and to identify exactly what is to be done to resolve this. Once you have that scoped out we can talk about how we get that implemented. :)

#2 Updated by Anonymous over 2 years ago

Having received feedback that this isn’t at all clear about what happens next:

The immediate step is that I need you, Pieter, to make the following decisions:

  • which console log mechanism is going to exist in Telly?
  • what does that change for our users?
  • what documentation effect does that have?
  • what other changes need to be made in Puppet to reflect this?

Specifically, if the new log mechanism is going to continue to exist I need to know the full set of UX requirements around it: where it works, how it works, how compatibility is maintained or broken, what documentation changes are required, and any other UX drivers that I am not aware of yet.

#3 Updated by Anonymous over 2 years ago

  • Status changed from Needs Decision to Accepted
  • Assignee changed from Anonymous to Anonymous

After talking to Pieter, we are going to make the new style the default, then see what adjustments need to be made.

#4 Updated by Anonymous over 2 years ago

  • Status changed from Accepted to In Topic Branch Pending Review
  • Branch set to https://github.com/puppetlabs/puppet/pull/692

https://github.com/puppetlabs/puppet/pull/692 fixes this, and cleans up any spec test failures.

#5 Updated by Anonymous over 2 years ago

  • Status changed from In Topic Branch Pending Review to Code Insufficient

It turns out that this drops the context from various messages – including “which resource a change applied to”.

#6 Updated by Anonymous over 2 years ago

  • Target version changed from 3.x to 3.0.0

#7 Updated by Anonymous over 2 years ago

The plan to correct this is that we will update the new console code to include the context – unless that is “Puppet” only. That still gives the right “what” most of the time, but reduces visual noise.

Comparing to the previous version of the console output mechanism will show how the context was included, but basically, msg.source.

#8 Updated by Chris Price over 2 years ago

Daniel—you had mentioned that some of the acceptance test failures for this branch would successfully highlight this problem. Can you point out which one(s) those were so that it will be easier to identify exactly what is going wrong here?

#9 Updated by Chris Price over 2 years ago

  • Assignee changed from Anonymous to Chris Price

#10 Updated by Anonymous over 2 years ago

  • Status changed from Code Insufficient to Merged - Pending Release

#11 Updated by Jeff McCune over 2 years ago

  • Status changed from Merged - Pending Release to Re-opened

Looks like this change breaks ANSI color output as described in #14675. Do you guys mind having a look before we release 3.0.0?

-Jeff

#12 Updated by Chris Price over 2 years ago

  • Status changed from Re-opened to Merged - Pending Release

#13 Updated by Chris Price over 2 years ago

re-closed this :) because the reference ticket was closed—the behavior described therein is expected (not a bug).

#14 Updated by Matthaus Owens about 2 years ago

  • Status changed from Merged - Pending Release to Closed

Released in Puppet 3.0.0rc1

Also available in: Atom PDF