The Puppet Labs Issue Tracker has Moved:

This issue tracker is now in read-only archive mode and automatic ticket export has been disabled. Redmine users will need to create a new JIRA account to file tickets using See the following page for information on filing tickets with JIRA:

Bug #13602

Please package puppet-lint for deb/rpm

Added by Michael Stahnke over 3 years ago. Updated almost 2 years ago.

Status:AcceptedStart date:04/03/2012
Priority:NormalDue date:
Assignee:-% Done:


Category:New PackageSpent time:-
Target version:-
Patch:None Branch:

We've Moved!

Ticket tracking is now hosted in JIRA:

This ticket is now tracked at:




#1 Updated by Jeff Weiss over 3 years ago

  • Category set to New Package
  • Status changed from Unreviewed to Accepted

#2 Updated by Russell Harrison about 3 years ago

I have already packaged puppet-lint for Fedora and EPEL. Its already in the Fedora stable repos and will be in the EPEL stable repos shortly (I submitted it for stable tonight). If anyone is using a Fedora or RHEL derivative they should always use the packages from those repos.

I am happy to help the Puppet Labs guys with their package especially as the current release of puppet-lint has a bug (already fixed in git) that requires patching.

#3 Updated by Dan White over 2 years ago

Thanks, Russel, but I see you only did one for RHEL 6. There are still a bunch of us on RHEL 5.

Would you be able to do a RHEL 5 version, please ?

#4 Updated by Jason Antman about 2 years ago

Yeah, I can confirm there’s still nothing in EPEL for puppet-lint; there’s a packge in rpmforge (yuck) but it’s ancient – 0.1.6. For now I’ve been installing the puppet-lint via gem on my CentOS 5.5 machines.

Especially since PL already packages dependencies, it would be really nice to have puppet-lint available. I can volunteer some time to assist any way I can.

#5 Updated by Charlie Sharpsteen almost 2 years ago

Redmine Issue #13602 has been migrated to JIRA:

Also available in: Atom PDF