The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #14368

documentation gap for non-trivial providers and types

Added by Philip Brown almost 2 years ago. Updated 4 months ago.

Status:ClosedStart date:05/08/2012
Priority:NormalDue date:
Assignee:Mike Hall% Done:

0%

Category:-
Target version:-
Keywords: Affected URL:
Branch:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

(this bug being filed as per discussion on dev mailing list)

There is a lacking in the documentation for non-trivial resource providers. http://docs.puppetlabs.com/guides/complete_resource_example.html gives a fairly trivial “example”. There are no additional stepping stones given to implement a more interesting, yet “clean” provider. (one that is more fully featured, yet needs no back-end additional hacks such as the “user” class)

Additional information such as “ensurable” can be expanded to a full clause with subpproperties.

(Longer discussion at https://groups.google.com/forum/?fromgroups#!topic/puppet-dev/jX8NQvdYQEA)

History

#1 Updated by James Turnbull almost 2 years ago

  • Project changed from Puppet to Puppet Documentation
  • Category deleted (documentation)

#2 Updated by Mike Hall over 1 year ago

  • Status changed from Unreviewed to Investigating
  • Assignee set to Mike Hall

#3 Updated by Mike Hall over 1 year ago

From community feedback over Twitter on similar issue of lacking examples:

  • inheriting class parameters (global config vars outside of facter)
  • running package sync before installs

#4 Updated by Nick Fagerlund 4 months ago

  • Status changed from Investigating to Rejected

Yeah, this matters, but it’s less urgent on account of the Dan & Nan book. SOMEDAY.

#5 Updated by Nick Fagerlund 4 months ago

  • Status changed from Rejected to Closed

I’m closing this ticket for housekeeping reasons, since we’re moving to a new ticketing system at https://tickets.puppetlabs.com.

There’s not a direct analogue to this ticket in the new tracker yet. If you’re still interested in this issue, you can make a new ticket once the new tracker goes publicly available in several days.

For this particular ticket, overhauling the type/provider docs is a big enough deal that we’ll be treating it as planned work and making probably a dozen sub-tickets once we’ve dealt with our current priorities. In the meantime, though, we won’t be tracking that work in Redmine. Sorry for any confusion I caused by marking this as “rejected!”

Also available in: Atom PDF