The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #14702

rubygem-activerecord not available for EL6

Added by David Schmitt over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:05/25/2012
Priority:NormalDue date:
Assignee:Will Hopper% Done:

0%

Category:New PackageSpent time:-
Target version:-
Patch: Branch:
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

When installing puppet-server from yum.puppetlabs.com,rubygem-activerecord is needed for storeconfigs, but is not available. There was a version from EPEL5, but isn’t in EPEL6 anymore. Using the version from EPEL5 works for the moment, but is an ugly clutch.

History

#1 Updated by Kelsey Hightower about 2 years ago

David Schmitt,

Thanks for reporting this. I’m moving this ticket over to the release team for better visibility.

#2 Updated by Kelsey Hightower about 2 years ago

  • Project changed from Puppet to Puppet Community Package Repository

#3 Updated by Michael Stahnke about 2 years ago

  • Status changed from Unreviewed to Needs Decision
  • Assignee set to Matthaus Owens

I’d really recommend switching to PuppetDB and away from ActiveRecord when it’s possible for you.

I maintain the AR packages in EPEL. The reason it isn’t yet in 6 is a versioning issue. I’d like put in rails3 obviously, but Puppet doesn’t work with that one either. So, having AR in EPEL 6 probably wouldn’t help this situation.

I’ll talk to the release team and see if they want to build out AR 2.3.14 (with known security issues) on yum.puppetlabs.com.

#4 Updated by Matthaus Owens about 2 years ago

  • Category set to New Package
  • Status changed from Needs Decision to Accepted
  • Assignee changed from Matthaus Owens to Moses Mendoza

We can rebuild the epel 5 rpm for el6 and host that, but as Mike says, moving to PuppetDB will be a better long term solution.

#5 Updated by Moses Mendoza about 2 years ago

  • Assignee changed from Moses Mendoza to Will Hopper

#6 Updated by Will Hopper about 2 years ago

  • Status changed from Accepted to Closed

Rebuilt activerecord from el5 for el6, as well as activesupport, as it is a dependency. Packages pushed to yum.puppetlabs.com.

Also available in: Atom PDF