The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #14946

Typo in "puppet" output

Added by Josh Baird over 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:06/11/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Affected Puppet version: Branch:
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

When an agent is administratively disabled, the following error is displayed:

root@fc-wrform01:~$ puppet agent -t notice: Skipping run of Puppet configuration client; administratively disabled; use ‘puppet Puppet configuration client —enable’ to re-enable.

This syntax does not make sense. It should read:

‘puppet agent —enable’


Related issues

Duplicated by Puppet - Bug #15122: Incorrect error message when running Puppet Agent that is... Duplicate 06/19/2012

History

#1 Updated by Matthaus Owens over 2 years ago

  • Project changed from Puppet Enterprise (Public) to Puppet
  • Status changed from Unreviewed to Accepted

Josh, Thanks for the report. I’m moving this to core puppet as this isn’t a Puppet Enterprise specific problem.

#2 Updated by Matthaus Owens over 1 year ago

  • Status changed from Accepted to Closed

This was addressed in commit af12688a32249943e4bd418e2466b2e24e570304 which was released in Puppet 3.0.0

Also available in: Atom PDF