The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #15767

Restrict pluginsync to a 'whitelist' of directories

Added by eric sorenson over 1 year ago. Updated over 1 year ago.

Status:Needs DecisionStart date:07/31/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:plug-ins
Target version:3.x
Affected Puppet version: Branch:
Keywords:telly_deprecation

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This ticket may be automatically exported to the PUP project on JIRA using the button below:


Description

Similar to the existing ‘pluginsignore’ option, it’d be good to have a whitelist of plugin-sync-able directories that defaulted to a sane set of things that would be useful to the client:

lib/facter lib/puppet/types lib/puppet/providers lib/puppetX

(This last is from #14149)

This would prevent parser functions from being sent down to agents, in keeping with the philosophy that pluginsync should only be used for things that extend the agent-to-master interaction.

History

#1 Updated by eric sorenson over 1 year ago

  • Status changed from Unreviewed to Needs Decision

Also available in: Atom PDF