The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #19109

Ubuntu 12.04 package puppet-common depends on ruby 1.9 packages that don't exist

Added by Igor Galić about 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Matthaus Owens% Done:

0%

Category:package
Target version:3.2.0
Affected Puppet version:3.1.0 Branch:
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

This makes a puppet installation with ruby 1.9 impossible.

Right now puppet-common depends on

libshadow-ruby1.8 | ruby-shadow, libaugeas-ruby1.8 | libaugeas-ruby1.9 

However, there is no package for ruby-shadow, and neither is there one for libaugeas-ruby1.9 (there is one for libaugeas-ruby1.9.1).

This makes an installation based on ruby 1.9 impossible.


Related issues

Related to Puppet Community Package Repository - Bug #19138: puppet-common on wheezy installs both ruby1.8 and ruby1.9.1 Closed
Related to Puppet - Bug #18985: Augeas should install libaugeas-ruby1.9.1 package on Ruby... Closed
Duplicated by Puppet Community Package Repository - Bug #20737: Package puppet-common refers to invalid package libaugeas... Duplicate

History

#1 Updated by eric sorenson about 1 year ago

  • Subject changed from Ubuntu 12.04 package puppet-common depends on ruby 1.9 packages that don't to Ubuntu 12.04 package puppet-common depends on ruby 1.9 packages that don't exist
  • Description updated (diff)
  • Category set to package
  • Status changed from Unreviewed to Investigating
  • Assignee set to Matthaus Owens

haus – can you look into this please?

#2 Updated by Joe Thompson about 1 year ago

So there are some additional issues with this that I found today when someone updated our apt repos and 3.1 got pushed out unexpectedly.

The biggest is that the ubuntu passenger is linked against 1.8.7 and there is no rubygems1.9.1 ubuntu package. This means it is not possible to compile a gem against 1.9.1 even though it’s available on the system.

So if you are running a master in passenger with an enc, you cannot currently upgrade to 3.1/1.9.1 without compiling your own rubygems install.

I mention the enc part because what initially caused us issues with the upgrade is the new yaml validation that requires 1.9 breaks enc functionality on 1.8.7, so our nodes were getting errors and could only apply the cached catalog.

#3 Updated by Igor Galić about 1 year ago

Joe, in 1.9 gem is part of the ruby1.9 package:

% apt-file search /usr/bin/gem | grep 1.9
ruby1.9.1: /usr/bin/gem1.9.1
ruby1.9.3: /usr/bin/gem1.9.3

#4 Updated by Joe Thompson about 1 year ago

Someone else told me that just now. I love how ubuntu strives for consistency. :)

#5 Updated by Igor Galić about 1 year ago

/* no comment */

#6 Updated by Michael Moll about 1 year ago

This is related to

18985

19138

#7 Updated by Matthaus Owens about 1 year ago

  • Status changed from Investigating to In Topic Branch Pending Review

Here’s a pull with the libaugeas fix: https://github.com/puppetlabs/puppet/pull/1587

Unfortunately, precise didn’t ship with ruby-shadow for 1.9, but quantal and raring do (ideally their ruby-shadow package would be installable on precise).

#8 Updated by Matthaus Owens about 1 year ago

  • Target version set to 3.2.0

#9 Updated by eric sorenson about 1 year ago

  • Status changed from In Topic Branch Pending Review to Merged - Pending Release

The pull request which addresses this and its related bugs was merged in https://github.com/puppetlabs/puppet/commit/987190e185811ec52270df811292be0dc0aa65bd

#10 Updated by Matthaus Owens about 1 year ago

  • Status changed from Merged - Pending Release to Closed

Released in Puppet 3.2.0-rc1

#11 Updated by Matthaus Owens about 1 year ago

Released in Puppet 3.2.0-rc1

Also available in: Atom PDF