The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #2727

XMLRPC returned wrong size. Retrying.

Added by Julien Cornuwel about 5 years ago. Updated over 2 years ago.

Status:ClosedStart date:10/15/2009
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:network
Target version:3.0.0
Affected Puppet version:0.24.8 Branch:
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

Some of my clients logs contain this line before each execution of puppet :

Oct 15 19:52:30 rails1 puppetd[14497]: XMLRPC returned wrong size.  Retrying.

Client and server both are 0.24.8 (Debian testing)

History

#1 Updated by Luke Kanies about 5 years ago

  • Category set to network
  • Status changed from Unreviewed to Needs More Information

Any other hints?

This is normally not actually a problem, but it’s pretty much all xmlrpc internal stuff – we make the error slightly less ugly, but we don’t throw and don’t have any visibility into why it even gets thrown.

#2 Updated by defunt Bode about 5 years ago

I see this sometimes when running 24.8 with webbrick. I just installed passenger, so I am not sure if it occurs there as well.

#3 Updated by Julien Cornuwel about 5 years ago

More hints ? Well, appart from that log message, puppet works fine. It only happens on two of my servers which are all installed the same way (from Debian packages).

Any test/command you would like me to run ?

#4 Updated by Peter Couvares about 5 years ago

I can also reproduce. I’m running 0.24.7 on both client and server. I started seeing these (apparently innocuous) errors after I switched from the Ubuntu-supplied ruby-1.8.6 to Enterprise Ruby 1.8.7-20090928.

#5 Updated by Julien Cornuwel about 5 years ago

ruby 1.8.7 (72) here, not enterprise.

#6 Updated by Patrick Carlisle almost 3 years ago

  • Status changed from Needs More Information to Closed
  • Target version set to 3.x

XMLRPC has been removed in telly, so I think this is no longer a concern.

#7 Updated by Anonymous over 2 years ago

  • Target version changed from 3.x to 3.0.0

Also available in: Atom PDF