The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Refactor #3172

puppetrun's "--host" option is cumbersome

Added by Josh Anderson about 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:02/09/2010
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:executables
Target version:2.6.0
Affected Puppet version:0.25.4 Branch:http://github.com/jes5199/puppet/tree/bug/master/3172
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

Having to specify each host with “—host ” is cumbersome and makes puppetrun less flexible than it could be.

A better, more UNIX-like scheme for arguments would be:

puppetrun [options] host [host [...]]

Where everything after the options is assumed to be a hostname.

This would make triggering mass runs simpler:

puppetrun -p 10 `cat nodes.txt`

Using —host also doesn’t make much sense in light of the fact that hostnames are not optional: you must specify at least one.


Related issues

Related to Puppet - Bug #4061: puppetrun (aka kick) ignores bad options with no feedback Duplicate 06/23/2010

History

#1 Updated by James Turnbull about 4 years ago

  • Status changed from Unreviewed to Accepted
  • Target version set to 2.7.x

See also this thread:

http://groups.google.com/group/puppet-users/browse_thread/thread/6a99a3f6624573c1

#2 Updated by Jesse Wolfe almost 4 years ago

  • Status changed from Accepted to In Topic Branch Pending Review
  • Target version changed from 2.7.x to 49
  • Branch set to http://github.com/jes5199/puppet/tree/bug/master/3172

#3 Updated by Markus Roberts almost 4 years ago

  • Status changed from In Topic Branch Pending Review to Closed
  • Target version changed from 49 to 2.6.0

Fixed in master (for 2.6.x) as commit:ebd03113d2c4024a7db603e73ca9f5dab34034c8

As it’s a refactor, not a bug fix, I’m changing the target from 0.25.6 to 2.6.

#4 Updated by Markus Roberts almost 4 years ago

Also commit:74e5bdce3b67a124616977c2e2c78c9506792c8f

Also available in: Atom PDF