The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #3834

APT package provider doesn't allow package downgrades

Added by Brane Gračnar almost 4 years ago. Updated almost 4 years ago.

Status:DuplicateStart date:05/21/2010
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Affected Puppet version:0.25.4 Branch:
Keywords:0.25.4, 0.25.5

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

It seems that apt package provider doesn’t provide functionality of package version downgrades.

apt-get —force-yes is marked as dangerous in apt-get(8) man pages, but it seems that is the only way to downgrade package.

Patch is included

puppet-provider-package-apt.patch Magnifier - this patch enables apt provider system package downgrades. (393 Bytes) Brane Gračnar, 05/21/2010 11:29 am


Related issues

Duplicates Puppet - Feature #1999: Provider "apt" for the package resource can't downgrade Closed 02/20/2009

History

#1 Updated by Paul Lathrop almost 4 years ago

  • Status changed from Unreviewed to Duplicate

Dupe of #1999, which has already been fixed.

Also available in: Atom PDF