The Puppet Labs Issue Tracker has Moved:

This issue tracker is now in read-only archive mode and automatic ticket export has been disabled. Redmine users will need to create a new JIRA account to file tickets using See the following page for information on filing tickets with JIRA:

Bug #7506

Decide exactly what versions of Ruby we support

Added by Matt Robinson almost 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:05/12/2011
Priority:NormalDue date:
Assignee:-% Done:


Target version:2.6.9
Affected Puppet version: Branch:
Keywords:puppet ruby version support

We've Moved!

Ticket tracking is now hosted in JIRA:


There has been a lot of talk about this, but so far the decision either hasn’t been made, or hasn’t been documented and communicated clearly. The impression I got from the testing meeting was that we only support Ruby 1.8.5 and 1.8.7 with a commitment to support 1.9.2 in 2.7.x. However, our public facing documentation states we support any version of Ruby 1.8.1 and above Our README file also states this

We need to either update the Docs site and README to clarify our ruby version support, or test more versions of Ruby.

Related issues

Related to Puppet - Bug #7265: Daemonized Puppet Master dies using Ruby 1.8.6 Closed 04/27/2011


#1 Updated by Jacob Helwig almost 5 years ago

Ruby 1.8.6 doesn’t appear to have ever worked with a daemonized master (See #7265).

#2 Updated by Matt Robinson almost 5 years ago

I talked to Nigel and Jason and Jacob and Daniel and Dominic and probably others about this, and it’s determined that we should change our documentation to be clearer about the versions of Ruby we support. Jason and Nigel will do the wordsmithing, but basically we’ll test against Ruby 1.8.5 and 1.8.7 for Puppet 2.6, and add Ruby 1.9.2 for Puppet 2.7. Once they’ve worded it how they’re happy, anyone should be able to update the appropriate places.

#3 Updated by Matt Robinson over 4 years ago

Pinging on this. All we need is the verbage written so we can get this committed and can point to somewhere when people ask us what versions of Ruby we support.

#4 Updated by Jason McKerr over 4 years ago

We support and test against Ruby 1.8.5 and 1.8.7 for all Puppet versions up to and including 2.6.x.

We make best effort support for Ruby 1.8.1, but do not execute our automated tests against that Ruby version.

For Puppet 2.7.x we wil support and test against Ruby 1.9.2 in addition to 1.8.5 and 1.8.7.

We do not support Ruby 1.8.6 and 1.9.0 and 1.9.1 because those versions are not included in major platform/OS distributions and they have compatibility issues with other versions of Ruby.

#5 Updated by Anonymous over 4 years ago

  • Status changed from Accepted to Closed

Thank you.

#6 Updated by Matt Robinson over 4 years ago

  • Status changed from Closed to Re-opened

Not sure why this was closed since no action was taken based on the text. The README needs to actually be updated.

#7 Updated by Matt Robinson over 4 years ago

  • Status changed from Re-opened to Merged - Pending Release
  • Assignee deleted (Jason McKerr)

NickF and I paired on this to update both 2.7rc commit:1a33bf86b74053f7978bddb6b1f715d04db9f2ba and 2.6.x commit:db1a392e3fce0d616b6d1061a123b60f61470f20. Nick is also updating the FAQ on the docs site.

#8 Updated by James Turnbull over 4 years ago

  • Status changed from Merged - Pending Release to Closed
  • Target version set to 2.6.9

Also available in: Atom PDF