The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #8800

1.2rc5 not working on Ubuntu Lucid 10.04 LTS

Added by Justin Honold about 3 years ago. Updated over 1 year ago.

Status:RejectedStart date:08/05/2011
Priority:NormalDue date:
Assignee:Michael Stahnke% Done:

0%

Category:-
Target version:-
Keywords: Affected URL:
Branch: Affected Dashboard version:

Description

undefined method `requirement' for #<Rails::GemDependency:0x7f8dbb42dad8>

is yielded when running 1.2rc5 with the following software versions –

Ruby: ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]
RubyGems: 1.3.5

If I revert to Dashboard v1.1.1, it works as expected. Based on the error, I’m only guessing that it’s Gem-version-related.

dashboard-fix-requirements-lucid.patch Magnifier (539 Bytes) Michel Loiseleur, 08/08/2011 09:05 am

History

#1 Updated by Michel Loiseleur about 3 years ago

I can confirm this bug on Ubuntu LTS, with packaged ruby & rubygems

ruby         1.8.7.249-2
rubygems1.8  1.3.5-1ubuntu2

I encountered it on 1.2rc3 and 1.2rc6. It’s caused by the continuous API breakage from RubyGems devs.

I’ve made a fix working for me, I’ve attached it to this issue. Feel free to contact an official Puppet developper, in order to apply it on master.

Regards,

#2 Updated by Justin Honold about 3 years ago

Thx! The patch applies cleanly.

I’ve run into another, perhaps unrelated issue during ‘rake RAILS_ENV=production db:create’:

“Couldn’t create database for {"encoding”=>“utf8”, “adapter”=>“mysql”, “username”=>“username”, “database”=>“database”, “password”=>“password”}, charset: utf8, collation: utf8_unicode_ci (if you set the charset manually, make sure you have a matching collation)"

I have tried manually matching the charset and collation to no avail. So, still not working on 10.04.

ruby: ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux] rubygems: 1.3.5 rake: rake, version 0.8.7

#3 Updated by Zach Leslie about 3 years ago

  • Affected Dashboard version set to 1.2rc7

#4 Updated by Jacob Helwig about 3 years ago

  • Status changed from Unreviewed to Closed

The recommended way to run Dashboard on Ubuntu 10.04 has involved installing a newer copy of RubyGems since v1.0.3. Specifically the recommended version is RubyGems 1.3.7. The Dashboard manual has instructions for installing RubyGems 1.3.7. The patch attached to this ticket does appear to fix the start-up issue, but we can’t make any guarantees that there aren’t (or won’t be) any other lurking issues around running RubyGems 1.3.5.

#5 Updated by Justin Honold about 3 years ago

  • Status changed from Closed to Re-opened

Could this decision be reconsidered? The Dashboard manual pushes an unpackaged (tarball) installation of a specific, still out-of-date Gem version. What feature of a newer RubyGems installation does Dashboard demand?

Like many other 10.04 users I’ve encountered on the IRC channel, I use stock Ruby, stock RubyGems, and Gem-based Puppet. This keeps me current with Puppet without going outside of official package management channels: debs from Ubuntu, gems from Puppet. A new-RubyGems policy would push me toward using an old Dashboard, not using Dashboard, or manually tinkering with my existing infrastructure. I would likely make a custom RubyGem package, but this is a process that might be repeated by countless other admins. I don’t think system-changing tarballs are a good thing to endorse, if it can be reasonably avoided. Can it? Thanks!

#6 Updated by Michael Stahnke almost 3 years ago

  • Status changed from Re-opened to Needs Decision

The patch included in this ticket updates vendored code. We don’t have a full test suite of the vendored code, because that is left to upstream for testing. We have no way to verify that change wouldn’t impact somebody running dashboard with the specified version of rubygems, etc. We don’t modify vendored code.

The dashboard manual points out how to resolve this issue. I totally agree it’s a pain, and I’m sorry about that. Perhaps FPM could help you package up a newer rubygems?

We also offer Puppet Enterprise which includes the proper versions of rubygems, ruby, dashboard etc for Lucid.

#7 Updated by Michel Loiseleur almost 3 years ago

Hi,

I have submitted the patch upstream. I don’t how if they will do something about it. Feel free to add comments on the upstream issue in order to get the fix applied.

https://github.com/rails/rails/pull/2819

Regards,

#8 Updated by James Turnbull almost 3 years ago

  • Assignee set to Michael Stahnke

#9 Updated by Aaron Stone over 1 year ago

  • Status changed from Needs Decision to Rejected
  • Affected Dashboard version deleted (1.2rc7)

No updates in a year, I hope this is moot by now.

#10 Updated by Justin Honold over 1 year ago

Couldn’t tell you anymore, TBH: I’m not longer in an Ubuntu production environment.

I did talk to a (the?) Rails committer on IRC FWIW, and he did express an intention of resolving it upstream.

As far as I’m concerned, safe to reject.

Also available in: Atom PDF