The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #9027

groupadd provider throws spurious warnings about AIX feature on non-AIX platforms.

Added by Jeremy Bowers over 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:08/16/2011
Priority:NormalDue date:
Assignee:Josh Cooper% Done:

0%

Category:group
Target version:2.7.6
Affected Puppet version:2.7.3 Branch:https://github.com/puppetlabs/puppet/pull/151
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

info: /Group[developer]: Provider groupadd does not support features manages_aix_lam; not managing attribute ia_load_module

Not sure when it started but seems to be related to #7137

I can reproduce this bug by creating a group on a non-AIX system (Mine is Ubuntu 10.04 LTS)

class users::developers {
  group { "developer":
    ensure => present,
    gid    => '1001',
  }
}

Related issues

Duplicated by Puppet - Bug #10135: Spurious message about "manages_aix_lam" when managing gr... Duplicate 10/17/2011

History

#1 Updated by hai wu over 3 years ago

I am using puppet 2.7.3 formal release (for both client and server), and I am still hitting this exact same bug ..

#2 Updated by Andrew Rankin over 3 years ago

I’m on CentOS 5.6, same deal:

info: /Group[ganglia]: Provider groupadd does not support features manages_aix_lam; not managing attribute ia_load_module
info: /Group[xymon]: Provider groupadd does not support features manages_aix_lam; not managing attribute ia_load_module
info: /Group[puppet]: Provider groupadd does not support features manages_aix_lam; not managing attribute ia_load_module

#3 Updated by Trevor Vaughan over 3 years ago

  • Affected Puppet version changed from 2.7.1 to 2.7.3

Removing line 108 from puppet/type/group.rb eliminates this spurious warning.

The line is:

defaultto "compat"

This makes it match the user type.

#4 Updated by James Turnbull over 3 years ago

  • Category set to group
  • Status changed from Unreviewed to Accepted
  • Assignee set to Jacob Helwig
  • Target version set to 2.7.x

Jacob – I can replicate this also.

#5 Updated by Steve Snodgrass about 3 years ago

I’m seeing this same problem on RHEL6 after upgrading from 2.6.9 to 2.7.4.

info: /Group[foobar]: Provider groupadd does not support features manages_aix_lam; not managing attribute ia_load_module

This error issues once for every managed user/group on the system, so my “puppet agent -t” output is pretty ugly now.

#6 Updated by Remi Broemeling about 3 years ago

Encountering this issue on RHEL 5.6 as well as CENTOS 5.6, using Puppet 2.7.5 and Facter 1.6.1. The error is new since our upgrade from Puppet 2.6.9 to 2.7.5. As Steve Snodgrass mentioned, it makes the puppet output pretty ugly — and more importantly makes the output of commands like ‘diff’ harder to parse at a glance — all of the warnings show up in the same color as changes that will occur to the system.

#7 Updated by Josh Cooper about 3 years ago

  • Status changed from Accepted to In Topic Branch Pending Review
  • Assignee changed from Jacob Helwig to Josh Cooper
  • Target version changed from 2.7.x to 2.7.5
  • Branch set to https://github.com/puppetlabs/puppet/pull/151

This change is ready to be merged. It is the “same” as was done for in commit 49c5152d64bb2d73a2751e9844bb2b92b14b88eb for issue #7137

#9 Updated by Michael Stahnke about 3 years ago

  • Status changed from In Topic Branch Pending Review to Merged - Pending Release

#10 Updated by Michael Stahnke about 3 years ago

  • Status changed from Merged - Pending Release to Closed
  • Target version changed from 2.7.5 to 2.7.6

´╗┐Released in 2.7.6rc1.

Also available in: Atom PDF