The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Platform-Specific Pages

Some of the community members have also created wiki pages devoted to notes on a particular platform:

Stable Platforms

Puppet can work well under a broad range of operating systems and system configurations. Below is a brief list of configurations with reported successes. If you have an operational configuration that isn’t listed here, please add it to the list:

-   CentOS 4/Linux 2.6 (x86\_64, i386, VMWare ESX 32-bit)
-   CentOS 5/Linux 2.6 (athlon, i386, VMWare ESX 32-bit)
-   Darwin 8.9.1 (PowerPC, i386)
-   Debian 3.1 'sarge'/Linux 2.6 (i386, amd64)
-   Debian 4.0 'etch'/Linux 2.6 (i386, xen686, amd64, powerpc)
-   Debian 5.0 'lenny'/Linux 2.6 (xen686, amd64)
-   Fedora Core 2 (i386)
-   Fedora Core 3 (i386)
-   Fedora Core 4 (i386)
-   Fedora Core 5 (i386)
-   Fedora Core 6 (i386)
-   Fedora 7 (i386/x86\_64)
-   Fedora 8 (i386/x86\_64)
-   Fedora 9 (i386/x86\_64)
-   Fedora 10 (i386/x86\_64)
-   Fedora 11 (i386/x86\_64)
-   Fedora 12 (i386/x86\_64)
-   Fedora 13 (i386/x86\_64)
-   Fedora 14 (i386/x86\_64)
-   FreeBSD 4.7 (i386)
-   FreeBSD 6.0 (i386)
-   Gentoo Linux (x86\_64)
-   Mandriva Corporate Server 4 (i586)
-   OpenBSD 4.1 (i386)
-   OpenBSD 4.2 (i386)
-   OpenBSD 4.3 (i386)
-   Oracle Linux 4 (x86\_64)
-   Oracle Linux 5 (x86\_64)
-   OSX 10.x.x
-   RHEL 3 ES (VMWare ESX 32-bit)
-   RHEL 4 ES,AS (i386, x86\_64)
-   RHEL 5 (i386, x86\_64)
-   RHEL 6 (i386, x86\_64)
-   Solaris 2.6 (i386, sparc)
-   Solaris 7 (i386, sparc)
-   Solaris 8 (i386, sparc)
-   Solaris 9 (i386, sparc)
-   Solaris 10 (i386, x86\_64, sparc64)
-   SuSE Linux 8/Linux 2.4 (i386)
-   SuSE Linux Enterprise Desktop 10/Linux 2.6 (i586)
-   SuSE Linux Enterprise Server 10/Linux 2.6 (i586)
-   SuSE Linux Enterprise Server 9/Linux 2.6 (i586, x86\_64)
-   Ubuntu 7.04 Feisty GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 7.10 Gutsy GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 8.04 Hardy GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 8.10 Intrepid GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 9.04 Jaunty GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 10.04 GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 10.10 GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 10.10 GNU/Linux 2.6 (i686, xen686)
-   Ubuntu 11.04 GNU/Linux 2.6 (i686, xen686)

Puppet Labs internally runs Quality Assurance Testing on:

  • Enterprise Linux 5/6 (Red Hat, Oracle, Scientific, CentOS)
  • Ubuntu LTS releases (Lucid currently, precise very soon)
  • SLES 11.1 (currently working to add 11 SP 2)
  • Solaris 10 (SPARC and i386)
  • Debian Squeeze
  • WIndows 2003/2008

Platforms Known to work and tested at Puppet Labs but not through the QA Matrix system:

  • Mac OS X
  • Fedora (currently supported versions)
  • Ubuntu (non LTS)
  • OpenSUSE (currently supported versions)
  • Amazon Linux

Platforms Supported by the community:

  • AIX
  • FreeBSD
  • Gentoo Linux
  • Darwin
  • OpenBSD
  • OpenIndiana
  • HP-UX
  • Arch Linux
  • Mandriva Linux