The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Russell Jackson

  • Email:
  • Registered on: 06/03/2008
  • Last connection: 03/20/2011

Activity

Reported issues: 6

06/06/2012

04:46 pm Puppet Bug #14560: package/apt provider needs to allow holding and ensuring a particular version at the ...

This [serverfault](http://serverfault.com/questions/370266/puppet-using-ensure-with-package-version-and-held) thread...
12:59 pm Puppet Bug #14560: package/apt provider needs to allow holding and ensuring a particular version at the ...
For example, I need to stay on mcollective 1.2 under squeeze. I could just ensure 1.2, but
then some idiot (me) will...

05/17/2012

01:46 pm Puppet Bug #14560 (Needs More Information): package/apt provider needs to allow holding and ensuring a p...
The package provider needs to be able to ensure a particular version of a package while also being able to set a hold...
01:39 pm Puppet Feature #639: Add 'hold' feature to apt and aptitude
I think I'll just open a new bug report instead of messing with this one.
01:31 pm Puppet Feature #639: Add 'hold' feature to apt and aptitude
Nigel Kersten wrote:
> I can't find the bug now, but I added "ensure => held" a while ago in another patch.
That app...

08/15/2011

11:10 pm MCollective Wiki edit: FreeBSD (#3)

04/26/2011

06:28 pm Puppet Bug #4996: FreeBSD package provider rewrite to use port origin when querying installed packages
I've `rake mail_patches` the current feature branch for review.
06:09 pm Puppet Feature #5951: Freebsd Package Manager rewrite (as fbsd)
Ticket #4996 has grown quite a bit since it was submitted. It now fetches and uses the package index to resolve port ...

03/27/2011

06:28 am Puppet Bug #4760: remove freebsd ports provider
Ticket obsoleted by new patch in #4996. Please close.

02/01/2011

04:47 am Puppet Bug #6096: FreeBSD package removal
See #4996. Another competing patch was posted to the dev list not too long ago.

Also available in: Atom