The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #10089

The usage of Facts in Ruby DSL is not documented

Added by Egon Kastelijn over 2 years ago. Updated 10 months ago.

Status:ClosedStart date:10/14/2011
Priority:NormalDue date:
Assignee:Nick Fagerlund% Done:

0%

Category:-
Target version:-
Keywords:ruby dsl facts Affected URL:
Branch:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

http://projects.puppetlabs.com/projects/1/wiki/Ruby_Dsl

The above page documents how to use the Ruby DSL. The problem is that it is unclear/undocumented how to use Agent Facts.

Someone mentioned that “Facter[:operatingsystem].value” should return the operatingsystem of the Agent, but this returns the operatingsystem of the PuppetMaster instead.

Please document in the page mentioned above how to use Facts in Ruby DSL.

puppet-2.6.8-1.el5


Related issues

Related to Puppet - Feature #16937: Improved Ruby DSL Closed 10/11/2012

History

#1 Updated by James Turnbull over 2 years ago

  • Description updated (diff)
  • Category set to documentation
  • Status changed from Unreviewed to Needs Decision
  • Assignee set to Nick Fagerlund

#2 Updated by Nick Fagerlund over 2 years ago

  • Project changed from Puppet to Puppet Documentation
  • Category deleted (documentation)
  • Support Urls deleted ()

Moving to the docs project.

#3 Updated by Nigel Kersten 10 months ago

  • Status changed from Needs Decision to Closed

Also available in: Atom PDF