The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

This issue tracker is now in read-only archive mode and automatic ticket export has been disabled. Redmine users will need to create a new JIRA account to file tickets using https://tickets.puppetlabs.com. See the following page for information on filing tickets with JIRA:

Bug #11887

Package with different providers should not violate duplicity

Added by Hunter Haugen over 4 years ago. Updated almost 3 years ago.

Status:RejectedStart date:01/11/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Affected Puppet version:2.6.13 Branch:
Keywords:package, provider

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com


Description

In 2.6.12 this works:

package { "mysql-gem":
  ensure   => present,
  name     => 'mysql',
  provider => 'gem',
}
package { "mysql":
  ensure => present,
}

In 2.6.13 it gives this error:

Duplicate definition: Package[mysql] is already defined in file /tmp/packages.pp at line 5; cannot redefine at /tmp/packages.pp:8 on node training.puppetlabs.lan

This seems like regression


Related issues

Duplicates Puppet - Bug #1398: Common package name in two different providers Accepted 07/07/2008

History

#1 Updated by Anonymous over 4 years ago

  • Status changed from Unreviewed to Rejected

We are very unlikely to change the uniqueness criteria here; give the packages different names.

#2 Updated by James Turnbull over 4 years ago

  • Status changed from Rejected to Re-opened
  • Assignee set to Anonymous

Is there an explanation for the change though? We seem to havechanged behavior in a point release?

#3 Updated by Nick Lewis over 4 years ago

  • Status changed from Re-opened to Rejected

This change is due to #8596 (commit:fb2ffd6879f4c885fe29f70e3cf9bcde89cdc8e9), which fixed a bug where conflicts weren’t properly detected when the conflict was between the name of one resource and the title of another (resources are aliased with both their title and their name, hence conflict, but that aliasing behavior wasn’t working correctly). This behavior of multiple packages with different providers hasn’t ever worked (#1398), so this isn’t a regression.

#4 Updated by Anonymous almost 3 years ago

  • Assignee deleted (Anonymous)

Also available in: Atom PDF