The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

This issue tracker is now in read-only archive mode and automatic ticket export has been disabled. Redmine users will need to create a new JIRA account to file tickets using https://tickets.puppetlabs.com. See the following page for information on filing tickets with JIRA:

Bug #11888

Oracle keeps renaming their Linux version

Added by James Turnbull over 3 years ago. Updated almost 2 years ago.

Status:ClosedStart date:01/11/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:provider
Target version:3.0.0
Affected Puppet version: Branch:https://github.com/puppetlabs/puppet/pull/326
Keywords: customer

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com


Description

Everywhere in providers we cite OEL/OVM we also need to cite OracleLinux.

History

#1 Updated by James Turnbull over 3 years ago

  • Status changed from Unreviewed to In Topic Branch Pending Review
  • Assignee set to Anonymous
  • Branch set to https://github.com/puppetlabs/puppet/pull/326

Daniel – support ticket related.

#2 Updated by Jeff McCune over 3 years ago

  • Status changed from In Topic Branch Pending Review to Tests Insufficient
  • Assignee changed from Anonymous to James Turnbull

Needs test coverage

We need to have some test coverage before I can merge this in. I added an example for the up2date provider in the Gihub discussion.

#3 Updated by James Turnbull over 3 years ago

  • Status changed from Tests Insufficient to In Topic Branch Pending Review
  • Assignee changed from James Turnbull to Jeff McCune

Test coverage has been added.

#4 Updated by Jeff McCune over 3 years ago

  • Status changed from In Topic Branch Pending Review to Merged - Pending Release
  • Target version set to 2.7.10

#5 Updated by Jeff McCune over 3 years ago

  • Status changed from Merged - Pending Release to Code Insufficient

Wrong Integration Branch

This was merged into 2.7.x and it shouldn’t have been because Mike points out it breaks API compatibility with Facter in a minor version. This doesn’t work for the OS distributions.

I’m going to revert this in 2.7.x and then revert the revert for master to get things in the right place.

-Jeff

#6 Updated by Jeff McCune over 3 years ago

Note, this has to be done ASAP to make the 2.7.10 release.

#7 Updated by Jeff McCune over 3 years ago

  • Status changed from Code Insufficient to In Topic Branch Pending Review
  • Assignee changed from Jeff McCune to Anonymous

Reverted for 2.7.x

Pull Request: https://github.com/puppetlabs/puppet/pull/340

As a reminder, once merged into 2.7.x this will also revert the change in master once we merge up. We’ll need to revert the revert in master at that point.

#8 Updated by Anonymous over 3 years ago

  • Target version changed from 2.7.10 to 3.x

This is remerged, targetted to telly, because raising the minimum version of Facter required in a stable series is not permitted.

#9 Updated by Anonymous over 2 years ago

  • Status changed from In Topic Branch Pending Review to Merged - Pending Release
  • Target version changed from 3.x to 3.0.0

#10 Updated by Matthaus Owens over 2 years ago

  • Status changed from Merged - Pending Release to Closed

Released in Puppet 3.0.0rc1

#11 Updated by Charlie Sharpsteen about 2 years ago

  • Keywords set to customer

#13 Updated by Anonymous almost 2 years ago

  • Assignee deleted (Anonymous)

Also available in: Atom PDF