The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #13107

Augeas type broken in 2.7.12 and ubuntu lucid

Added by Juan José Presa Rodal about 2 years ago. Updated over 1 year ago.

Status:AcceptedStart date:03/14/2012
Priority:NormalDue date:
Assignee:Nick Lewis% Done:

0%

Category:augeas
Target version:-
Affected Puppet version:2.7.12 Branch:
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This ticket may be automatically exported to the PUP project on JIRA using the button below:


Description

I have some custom modules in my environment that makes use of augeas type. Since release 2.7.12 i have this error:

err: /Stage[main]/foo/Augeas[bar]/returns: change from need_to_run to 0 failed: private method `load' called for #<Augeas:0xb65788dc>

Im tried to upgrade augeas tool and libraries from main repo to PPA one with upgraded version of augeas libraries (0.7.4) and the error continues.

If I downgrade puppet to 2.7.11 all the modules finish correctly.

Thanks in advance


Related issues

Related to Puppet - Bug #11988: Augeas provider can clobber symlinks Closed 01/17/2012
Related to Puppet Community Package Repository - Bug #16203: puppet-common on ubuntu lucid only works with libaugeas-r... Accepted 08/31/2012

History

#1 Updated by Patrick Carlisle about 2 years ago

  • Category set to augeas
  • Status changed from Unreviewed to Investigating
  • Assignee set to Nick Lewis

Nick, this appears related to the change you made.

#2 Updated by Nick Lewis about 2 years ago

It seems we inadvertently introduced a dependency on Augeas >= 0.7.3, and Ruby Augeas bindings >= 0.3.0. A fix will be coming, but before it’s released, upgrading both of those should resolve the problem.

#3 Updated by Nick Lewis about 2 years ago

  • Status changed from Investigating to Accepted

#4 Updated by Juan José Presa Rodal about 2 years ago

Upgrading both workarounds the problem. Checked with skettler PPA packages.

Waiting for the patch. Thanks again!

#5 Updated by Dominic Cleal about 2 years ago

I’ve filed a backport request for ruby-augeas 0.3.0: LP#958152. It’s probably a good idea to mark the bug as affecting you if it’d be useful, in the hope it gets some attention.

I think the minimum Augeas version will be 0.5.1 rather than 0.7.x, which Lucid easily surpasses.

#6 Updated by Dominic Cleal about 2 years ago

  • Affected Puppet version deleted (2.7.12rc2)

The backport has been swiftly actioned, you’ll find libaugeas-ruby 0.3.0-1.1ubuntu1~lucid1 available via lucid-backports.

I don’t know what you intend to do Nick – either workaround it, or set a minimum version of 0.3.0 on the package? The only thing I’m concious of now is that I implemented #7285 in Telly which also uses the same aug_load method.

#7 Updated by Dominic Cleal about 2 years ago

  • Affected Puppet version set to 2.7.12

Also available in: Atom PDF