The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

This issue tracker is now in read-only archive mode and automatic ticket export has been disabled. Redmine users will need to create a new JIRA account to file tickets using https://tickets.puppetlabs.com. See the following page for information on filing tickets with JIRA:

Bug #13317

Storeconfig error with postgresql

Added by Svein Harald Soleim about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:03/22/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Affected Puppet version:2.7.12 Branch:
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com


Description

I’m using CentOS 6.2 with http://yum.puppetlabs.com. When I run puppetmaster from init.d I get pgsql errors in the log:

Mar 22 09:58:13 puppet puppet-master[7156]: could not connect to server: Permission denied#012#011Is the server running on host "puppet.example.com" and accepting#012#011TCP/IP connections on port 5432?#012could not connect to server: Permission denied#012#011Is the server running on host "puppet.example.com" and accepting#012#011TCP/IP connections on port 5432?

But when I run it from commandline it seems to run fine

puppet master --verbose --no-daemonize --masterport 8140
notice: Starting Puppet master version 2.7.12
info: access[^/catalog/([^/]+)$]: allowing 'method' find
info: access[^/catalog/([^/]+)$]: allowing $1 access
info: access[^/node/([^/]+)$]: allowing 'method' find
info: access[^/node/([^/]+)$]: allowing $1 access
info: access[/certificate_revocation_list/ca]: allowing 'method' find
info: access[/certificate_revocation_list/ca]: allowing * access
info: access[/report]: allowing 'method' save
info: access[/report]: allowing * access
info: access[/file]: allowing * access
info: access[/certificate/ca]: adding authentication any
info: access[/certificate/ca]: allowing 'method' find
info: access[/certificate/ca]: allowing * access
info: access[/certificate/]: adding authentication any
info: access[/certificate/]: allowing 'method' find
info: access[/certificate/]: allowing * access
info: access[/certificate_request]: adding authentication any
info: access[/certificate_request]: allowing 'method' find
info: access[/certificate_request]: allowing 'method' save
info: access[/certificate_request]: allowing * access
info: access[/status]: adding authentication any
info: access[/status]: allowing 'method' find
info: access[/status]: allowing 'method' save
info: access[/status]: allowing * access
info: access[/]: adding authentication any
info: access[/]: adding environment production
info: access[/]: allowing * access
info: Connecting to postgresql database: puppet
info: Expiring the node cache of puppetnode2.example.com
info: Not using expired node for puppetnode2.example.com from cache; expired at Thu Mar 22 10:06:51 +0100 2012
info: Caching node for puppetnode2.example.com

The database also comfirms that the commandline works.

I’m using the following gems:

* abstract (1.0.0)
* actionmailer (3.0.11)
* actionpack (3.0.11)
* activemodel (3.0.11)
* activerecord (3.0.11)
* activeresource (3.0.11)
* activesupport (3.0.11)
* arel (3.0.2, 2.0.10)
* builder (3.0.0, 2.1.2)
* bundler (1.1.2)
* erubis (2.7.0, 2.6.6)
* fastthread (1.0.7)
* hike (1.2.1)
* i18n (0.6.0, 0.5.0)
* journey (1.0.3)
* json (1.6.5)
* mail (2.4.4, 2.2.19)
* mime-types (1.18)
* multi_json (1.1.0)
* pg (0.13.2)
* polyglot (0.3.3)
* postgres (0.8.1)
* rack (1.4.1, 1.2.5, 1.1.0)
* rack-cache (1.2)
* rack-mount (0.6.14)
* rack-ssl (1.3.2)
* rack-test (0.6.1, 0.5.7)
* rails (3.2.2)
* railties (3.2.2)
* rake (0.9.2.2)
* rdoc (3.12)
* sprockets (2.1.2)
* stomp (1.1.8)
* thor (0.14.6)
* tilt (1.3.3)
* treetop (1.4.10)
* tzinfo (0.3.32)

History

#1 Updated by Chris Price about 4 years ago

  • Status changed from Unreviewed to Needs More Information
  • Assignee set to Svein Harald Soleim

Svein,

Could you provide a little more info to help us try to reproduce?

  1. Postgres version?
  2. When did this start happening for you? Was it working before? Did you upgrade puppet, or postgres, or both? Or is this from a clean installation of both?
  3. Anything interesting in your manifests that we should take into account when trying to repro this?

Thanks!

#2 Updated by Svein Harald Soleim about 4 years ago

  1. Postgres 8.4.9
  2. Clean install new vm.
  3. No nothing special, I’m learning puppet as I go so its minimal. I’m only distributing ssh-server keys with pgsql backend as of now.

#3 Updated by Chris Price about 4 years ago

  • Status changed from Needs More Information to Investigating
  • Assignee changed from Svein Harald Soleim to Chris Price

#4 Updated by Chris Price about 4 years ago

  • Assignee changed from Chris Price to Patrick Carlisle

#5 Updated by Anonymous about 4 years ago

  • Assignee changed from Patrick Carlisle to Anonymous

#6 Updated by Anonymous about 4 years ago

  • Status changed from Investigating to Accepted

I’ve been able to reproduce this on a VM. Svein, thanks for the clear information, it helped a lot in getting a similar setup here and seeing the problem. Here is the list of steps that I used to get to a place where it occured:

  1. Installed base CentOS 6.2 VM from ISO http://mirror.spro.net/centos/6.2/isos/x86_64/CentOS-6.2-x86_64-netinstall.iso using a minimal install
  2. Setup puppet repo pointed to el/6/products/x86_64 & el/6/dependencies/x86_64
  3. yum install ruby
  4. yum install postgresql
  5. yum install puppet
  6. yum install puppet-server
  7. yum install postgresql-server
  8. yum install postgresql-devel
  9. setup puppet.conf as per http://projects.puppetlabs.com/projects/1/wiki/Using_Stored_Configuration
  10. yum install rubygems
  11. yum install ruby-devel
  12. yum install gcc
  13. yum install make
  14. gem install pg -v 0.13.2
  15. the gems lists won’t install all together. Bundler claims many incompatibilities. Pairing down until it installs. (mainly the rails version is not compatible with many other versions, allowing the rails version to dictate the rest)
  16. created postgres db and user as per Using Stored Configuration link
  17. changed pg_hba.conf to use password instead of ident
  18. gem uninstall activerecord -v 3.2.2
  19. gem install activerecord -v 3.0.11

#7 Updated by Anonymous about 4 years ago

Turns out that this is selinux stopping the puppet master from accessing postgres.

#8 Updated by Anonymous about 4 years ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF