The Puppet Labs Issue Tracker has Moved:

This issue tracker is now in read-only archive mode and automatic ticket export has been disabled. Redmine users will need to create a new JIRA account to file tickets using See the following page for information on filing tickets with JIRA:

Bug #15820

Undefined method "empty_answer"

Added by Anonymous over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:08/03/2012
Priority:NormalDue date:
Assignee:-% Done:


Target version:-
Keywords: Affected Hiera-Puppet Version:

We've Moved!

Ticket tracking is now hosted in JIRA:



puppet* 3.0.0-0.1rc3puppetlabs1

hiera 1.0.0-0.1rc4

hiera-puppet 1.0.0-0.1rc1-1-g3e68ff0

When I run puppet agent --test I get the following:

Info: Retrieving plugin
Info: Loading facts in /etc/puppet/modules/stdlib/lib/facter/puppet_vardir.rb
Info: Loading facts in /etc/puppet/modules/stdlib/lib/facter/root_home.rb
Info: Loading facts in /etc/puppet/modules/stdlib/lib/facter/facter_dot_d.rb
Info: Loading facts in /etc/puppet/modules/custom/lib/facter/cluster_id.rb
Info: Loading facts in /etc/puppet/modules/custom/lib/facter/node_id.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
Info: Loading facts in /var/lib/puppet/lib/facter/cluster_id.rb
Info: Loading facts in /var/lib/puppet/lib/facter/node_id.rb
Info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Puppet::Parser::AST::Resource failed with error NoMethodError: undefined method `empty_answer' for Hiera::Backend:Module at /etc/puppet/environments/test/manifests/nodes/puppet_nodes.pp:47 on node ll-puppet-master-vm.XXXX
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run


# cat /etc/puppet/hiera.yaml
- %{node_id}
- common
- yaml
- puppet
:datadir: '/etc/puppet/hieradata'


# cat /etc/puppet/puppet.conf
archive_files = true
facts_terminus = yaml
dbuser = XXXXX
dbpassword = XXXXX
dbconnections = 75
reports = store

The section that is referenced in the error message:

class { 'basenode':
is_puppet_master => true;

And the class definition for basenode:

class basenode (
$is_puppet_master = false,
$apt_host = 'XXXXXXXXXXX'
) {


#1 Updated by Anonymous over 3 years ago

Updating to hiera-puppet 1.0.0-0.1rc2 resolved this issue, but introduced different ones.

#2 Updated by Mitchell Hashimoto over 3 years ago

To add to this. There is a bug in hiera-puppet 1.0.0-0.1rc1. RC2 fixes this, but for some reason, I think due to the structure of the version string, apt thinks 1.0.0-0.1rc1 is a LATER version than 1.0.0-0.1rc2. Easy enough, I can force the install of RC2.

After RC2 is installed, it is missing “hiera_puppet.rb,” so this actually needs to be retrieved from GitHub and put into the Ruby load path. This appears to be a packaging issue with hiera-puppet RC2.

Hopefully these are fixed up in RC3. :)

#3 Updated by eric sorenson over 3 years ago

  • Assignee set to Anonymous

Mitch / Lee — Did 1.0.0rc4 in fact fix this? I’m just coming up to speed on this project so I’m not sure what the exact state of play is.

#4 Updated by Anonymous over 3 years ago

I have not yet tested with rc3 or rc4, but I should be able to do so on Monday of next week.

I will give a proper update as soon as I am able to.

#5 Updated by eric sorenson over 3 years ago

  • Status changed from Unreviewed to Needs More Information

#6 Updated by Curtis Ruck over 3 years ago

I’m getting this issue in rc4.

#7 Updated by Bruno LEON over 3 years ago

rc3 fixes the empty_answer issue. It needs to be forced at install though because apt installs the rc1

#8 Updated by Anonymous over 3 years ago

  • Status changed from Needs More Information to Closed

Sorry for the delays in my response, life got busy.

This does seem to be fully fixed, I ran into it again, but that is because I forgot I needed to copy the files over still in 2.7.x and use pluginsync to get them into the right place. Closing this out.

Also available in: Atom PDF