The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Bug #16021

Vsphere credentials should not be stored in /etc

Added by Branan Purvine-Riley over 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:08/17/2012
Priority:NormalDue date:
Assignee:Scott Schneider% Done:

0%

Category:Harness
Target version:-
Patch:None Branch:
Keywords:

We've Moved!

Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com

This issue is currently not available for export. If you are experiencing the issue described below, please file a new ticket in JIRA. Once a new ticket has been created, please add a link to it that points back to this Redmine ticket.


Description

We should instead use the Fog configuration file for this.

History

#1 Updated by Branan Purvine-Riley over 1 year ago

  • Category set to Harness
  • Assignee set to Branan Purvine-Riley

#2 Updated by Justin Stoller over 1 year ago

  • Assignee changed from Branan Purvine-Riley to Scott Schneider

I added support to the harness a while ago. This is its output now:


Revert VMs
Use of /etc/plharness/vsphere as a config file is deprecated.
Please use ~/.fog instead
See http://docs.puppetlabs.com/pe/2.0/cloudprovisioner_configuring.html for format
Connecting to vsphere at qa-vsphere.puppetlabs.lan with credentials for root
Reverting oel-r5-u6-x86-64 to snapshot pe
Spent 4.93 seconds reverting

All that needs to be done now is ensure the ~/.fog file is in puppet and when we re-deploy the coordinators it will be all good. Assigning to Scott since I think may have already puppetized this.

#3 Updated by Justin Stoller about 1 year ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF