The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com
https://tickets.puppetlabs.com. See the following page for information on filing tickets with JIRA:
Ubuntu 12.04 package puppet-common depends on ruby 1.9 packages that don't exist
|Assignee:||Matthaus Owens||% Done:|
|Affected Puppet version:||3.1.0||Branch:|
Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com
This makes a puppet installation with ruby 1.9 impossible.
Right now puppet-common depends on
libshadow-ruby1.8 | ruby-shadow, libaugeas-ruby1.8 | libaugeas-ruby1.9
However, there is no package for ruby-shadow, and neither is there one for libaugeas-ruby1.9 (there is one for libaugeas-ruby1.9.1).
This makes an installation based on ruby 1.9 impossible.
#1 Updated by eric sorenson about 3 years ago
- Subject changed from Ubuntu 12.04 package puppet-common depends on ruby 1.9 packages that don't to Ubuntu 12.04 package puppet-common depends on ruby 1.9 packages that don't exist
- Description updated (diff)
- Category set to package
- Status changed from Unreviewed to Investigating
- Assignee set to Matthaus Owens
haus – can you look into this please?
#2 Updated by Joe Thompson about 3 years ago
So there are some additional issues with this that I found today when someone updated our apt repos and 3.1 got pushed out unexpectedly.
The biggest is that the ubuntu passenger is linked against 1.8.7 and there is no rubygems1.9.1 ubuntu package. This means it is not possible to compile a gem against 1.9.1 even though it’s available on the system.
So if you are running a master in passenger with an enc, you cannot currently upgrade to 3.1/1.9.1 without compiling your own rubygems install.
I mention the enc part because what initially caused us issues with the upgrade is the new yaml validation that requires 1.9 breaks enc functionality on 1.8.7, so our nodes were getting errors and could only apply the cached catalog.
#7 Updated by Matthaus Owens about 3 years ago
- Status changed from Investigating to In Topic Branch Pending Review
Here’s a pull with the libaugeas fix: https://github.com/puppetlabs/puppet/pull/1587
Unfortunately, precise didn’t ship with ruby-shadow for 1.9, but quantal and raring do (ideally their ruby-shadow package would be installable on precise).