The Puppet Labs Issue Tracker has Moved:

This issue tracker is now in read-only archive mode and automatic ticket export has been disabled. Redmine users will need to create a new JIRA account to file tickets using See the following page for information on filing tickets with JIRA:

Bug #4153

notice: Run of Puppet configuration client already in progress; skipping

Added by pengfei li almost 6 years ago. Updated almost 6 years ago.

Status:RejectedStart date:07/07/2010
Priority:NormalDue date:
Assignee:-% Done:


Target version:-
Affected Puppet version:0.25.5 Branch:
Keywords:client already in progress

We've Moved!

Ticket tracking is now hosted in JIRA:


Hello,I got a problem.When I run the command “puppetd —test —debug” on the client.I got a message “notice: Run of Puppet configuration client already in progress; skipping” .But onle one single server occured.Other servers run well.I tried to reinstall puppet,and clean the ssl certificate.It is useless.I don’t know why it happened,and how to fix it.Please help me out,thanks a lot!

Related issues

Related to Puppet - Bug #2888: puppetd doesn't always cleanup lockfile properly Needs More Information 12/04/2009
Related to Puppet - Bug #1254: puppetd client randomly hangs Closed
Related to Puppet - Bug #504: Puppetd lock files seem to be staying around Closed
Related to Puppet - Feature #190: Clear lockfile if the associated PID no longer exists Closed


#1 Updated by Yuri Krysko almost 6 years ago

Just remove file puppetdlock from /var/lib/puppet/state dir

Yuri –

#2 Updated by Peter Meier almost 6 years ago

  • Status changed from Unreviewed to Rejected

or run @puppetd —enable@

I’m closing the ticket, as this is the behavior that could also come from a @puppetd —disable@ run. However, in 0.25.x this can also happen from time to time, but there is already a ticket opened for the actual cause of that: #2888

Also available in: Atom PDF