The Puppet Labs Issue Tracker has Moved: https://tickets.puppetlabs.com

Puppet 2.7 and Ruby 1.9 Known Issues

Puppet 2.7 was the first release series to have any official support for Ruby 1.9. This page collects the major known issues that remain unfixed in the 2.7 series in a single location, to make it easier to understand the limitations of Puppet on the platform.

resource_statuses not reported in ruby 1.9

Issue #13245 – when running under Ruby 1.9, various internal changes in Ruby introspection code resulted in the detailed values under the resource_statuses key being omitted from reports. The change to resolve this is reasonably intrusive, and risks of the change are substantial. This will be fixed in Telly.